ハードなソフトの話

アクセスカウンタ

zoom RSS gnupack: 最新版のcurlがエラーで終了

<<   作成日時 : 2017/03/22 00:43   >>

ブログ気持玉 0 / トラックバック 0 / コメント 0

問題:

gnupack 13.06-2015.11.08で下記のように curl をインストールする

apt-cyg install curl

コマンドラインで実行すると下記のように失敗する。

image

以前は、確かにできていたので、最新版のcurlとの問題と思われる。

失敗するバージョンは、以下の通り:

version: 7.52.1-1

原因:

curl.exe で参照している関数”_locale_ctype_ptr ”がCYGWIN1.DLLに存在しない。

image

CYGWIN1.DLLを gnupack13.06と最新のCYGWINではバージョンではマイナーバージョンが違う。

gnupack 13.06 2.2.1
cygwinの最新 2.7.0

 

解決策(案):

  1. gnupackではなくCygwinの最新版を使う
    (あまり解決策になっていない)
  2. cygwin版ではなくWindows版のcurlを使う
    ( https://curl.haxx.se/download.html ?> Win32 ?Generic をダウンロード )
    (たぶん、面倒)
  3. gnupack が最新版のCygwinに対応するまで待つ
    (または、自分で何とかする)
  4. 自力でビルドする

 

参考

参考記事:  stackoverflow内

How do I install cURL on cygwin (latest versions checked in setup - cyg complains missing .DLL)

※ cygwin に cURLをインスールするには?(最新バージョンのSETUPで見つからないDLLがあるというエラーになる)

http://stackoverflow.com/questions/17473705/how-do-i-install-curl-on-cygwin-latest-versions-checked-in-setup-cyg-complain

テーマ

関連テーマ 一覧


月別リンク

ブログ気持玉

クリックして気持ちを伝えよう!
ログインしてクリックすれば、自分のブログへのリンクが付きます。
→ログインへ

トラックバック(0件)

タイトル (本文) ブログ名/日時

トラックバック用URL help


自分のブログにトラックバック記事作成(会員用) help

タイトル
本 文

コメント(0件)

内 容 ニックネーム/日時

コメントする help

ニックネーム
本 文
gnupack: 最新版のcurlがエラーで終了 ハードなソフトの話/BIGLOBEウェブリブログ
文字サイズ:       閉じる